ugg negozi roma Carico e scarico magazzino con Excel

ugg aus Carico e scarico magazzino con Excel

In questo tutorial impariamo ad usare Excel per generare un’applicazione di gestione del magazzino, ottimizzando le operazioni di carico e scarico in modo da tenere sotto controllo la soglia minima di merce. L’applicazione sarà costituita da tre fogli di lavoro:

PRODOTTI, con tabella in cui registrare la merce in magazzino, il fornitore e i pezzi in giacenza (calcolati sulla base delle forniture del foglio successivo): ogni volta che la giacenza raggiunge una soglia di guardia verrà segnalata la necessità di fornitura ulteriore.

SCARICO, con le merci in uscita: durante la trascrizione delle informazioni comparirà accanto ai dati la quantità residua del prodotto così da sapere quanti pezzi potranno essere scaricati. Se che ne indicheremo più di quanto presenti in giacenza, un messaggio di errore obbligherà a ridigitare un valore accettabile.

=> La scheda di magazzino con EXCELPosizioniamoci nel foglio “Carico”, digitiamo rispettivamente nelle celle A1; B1; C1 e D1: “Data”, “Prodotto”, “Fornitore” e “N Pezzi” e formattiamo a piacimento. La tabella servirà per archiviare le fasi di carico del magazzino (data di fornitura, merce, fornitore e quantità).

Generiamo un menù a tendina dal quale selezionare il prodotto da caricare scegliendolo fra quelli presenti nel primo foglio (“Prodotti”).

Scegliamo le celle su cui agire, nel nostro esempio l’intervallo B2:B5000. Selezioniamo la barra multifunzione “Dati” e clicchiamo su “Convalida dati”.

Nella finestra, posizioniamoci nella prima scheda (“Impostazioni”), apriamo il menù “Consenti” e selezioniamo “Elenco”. Nel campo “Origine” digitiamo =PRODOTTI!$A$2:$A$5000

L’intervallo di celle da noi scelto è volutamente ampio per poter archiviare una gran mole di merce. Clicchiamo OK.

Impostiamo ora le celle della colonna “Fornitori” in modo tale che, una volta scelto il prodotto, ci venga restituito automaticamente il fornitore di riferimento.

Al termine trasciniamo il quadratino di riempimento della cella C2 per ricopiare la formula nelle celle sottostanti. Nel nostro esempio fino a C5000.

Proviamo ora a collegare i primi due fogli per sommare quantità di merce inserita nel foglio “Carico” e quantità di merce presente nel foglio “Prodotti”. A tale scopo posizioniamoci nel foglio Prodotti e nella cella C2 digitiamo la formulaAl termine ricopiamo la formula fino a C5000.

Proviamo ora a compilare il foglio “Carico”: la quantità inserita verrà aggiunta a quella dei prodotti corrispondenti, nel primo foglio. Il valore ottenuto costituirà la giacenza del magazzino.

Lasciando così le cose, tuttavia, avremmo per assurdo la possibilità di inserire delle quantità di carico negative. Eseguendo i punti seguenti imporremo una regola che ce lo impedisca: selezioniamo le celle su cui agire, nel nostro esempio l’intervallo D2:D5000, attiviamo la barra multifunzione “Dati” e clicchiamo su “Convalida dati”.

Apriamo il menù “Consenti” e selezioniamo la voce “Personalizzato”. Nel campo “Formula” digitiamo =SE(D2

Facciamo click (in alto) nella scheda “Messaggio di errore” e digitiamo un messaggio di errore che venga visualizzato all’utente tutte le volte che questo scriverà un valore negativo. Confermiamo col tasto OK

=> Gestione ordini con Excel con magazzino limitatoPosizioniamoci nel foglio “SCARICO” e scriviamo nelle celle A1, B1 e C1 rispettivamente “Data”, “Prodotto venduto” e “N Pezzi Venduti”, dopodiché formattiamole a piacimento.

Una volta ricreata la tabella, potete impostare nelle celle della colonna B dei menù a tendina che consentano di scegliere la merce archiviata nel primo foglio (“PRODOTTI”), a tale scopo rieseguiamo le procedure già viste per il foglio “CARICO”.

Facciamo ora in modo che, una volta selezionato un prodotto, ci compaia accanto il numero di pezzi presenti in magazzino. Nella cella D2 trascriviamo la formula:

=SE(B2= cella E2: =SE(D2= in magazzino termine ricopiamo le formule nelle celle sottostanti.

Ora non appena inseriremo una data e selezioneremo un prodotto, ci comparirà a lato la giacenza dello stesso. Potremo così digitare il “N pezzi venduti”, verificando facilmente la giacenza in magazzino per quel prodotto. Ovviamente il valore trascritto non dovrà superare il deposito. Per dare risalto potete colorare i caratteri delle colonne D ed E di rosso.
ugg negozi roma Carico e scarico magazzino con Excel